This project is read-only.
1
Vote

elFinder.Connector.Integration.Autofac missing

description

the elFinder.Connector.Integration.Autofac refrence is missing and the elFinder.Connector.Integration.Autofac.dll does not exist in source or download package.
take a look at attachment
thank you

file attachments

comments

KZmorzynski wrote May 6, 2014 at 7:01 AM

Yes, in download package there's no elFinder.Connector.Integration.Autofac yet, but in source (latest commit) there is. Please check the "source code" tab here on codeplex - maybe you didn't download all the sources?

TonkoBoekhoud wrote May 8, 2014 at 9:38 AM

Downloaded complete source,
Tried to run elFinder.WebTest from vs13
Changed nothing, but got this error:

_An exception of type 'System.TypeInitializationException' occurred in elFinder.Connector.Integration.Autofac.dll but was not handled in user code

Additional information: The type initializer for 'elFinder.Connector.Config.AppConnectorConfig' threw an exception._

On the line

_builder.RegisterElFinderConnectorServices<DefaultVolumeManager, DefaultImageEditorService, Base64CryptoService>( AppConnectorConfig.Instance );
_
In Extensions.cs


Am I doing something wrong?



Thanks, Tonko

TonkoBoekhoud wrote May 12, 2014 at 1:09 PM

Found in elFinder.MVCTest web.config and added to elFinder.WebTest web.config :
<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
...

Works now. I would like to know if this is the way to go.


Regards, Tonko

KZmorzynski wrote May 12, 2014 at 2:33 PM

Yes, this is sometimes required when running on IIS 6 or in classic mode or in VS2010 WebDev server.