ElFinderConnector Error

Apr 17, 2014 at 4:02 PM
Hi, I had a similar problem with these two users:
https://elfinderaspnet.codeplex.com/discussions/445826
https://elfinderaspnet.codeplex.com/discussions/430725

I've tried the solution to fix .net 4.0 installation here as you recommended:
http://stackoverflow.com/questions/6846544/how-to-fix-handler-pagehandlerfactory-integrated-has-a-bad-module-managedpip

However it still doesn't solve my problem.

Below is the screenshot of my issue as well as my IIS settings.

Image
Image

When I tried accessing the connector at /elfinder.connector it gives me this error below. Therefore as you mentioned, the problem is probably with my httphandler?

Image

Settings on the web config, global.asax, etc was unchanged from your 'source code' page.

I've tried going through google trying to find solution on how to repair my httphandler. I've tried repair my .net installation, restart IIS, restart server, etc but still no luck.

Do you have any idea on how to fix this? Or did I do something wrong?

Your help is much appreciated. Thank you.
Apr 19, 2014 at 1:50 PM
Hi,

change "Managed pipeline" in IIS from "Classic" to "Integrated" and see if it will work.

best,
Chris
Apr 19, 2014 at 2:26 PM
Hi Chris, thank you for your answer.

I did try it, but after that I can't even open the site as it gives error saying something like the site uses ISAPI that can only be run using classic pipeline.

Kind regards,
Stefanto
Apr 19, 2014 at 3:36 PM
Stefano,

well, you should first try to run web site under "Integrated" pipeline mode. This error might indicate that there are some ISAPI filters running, but I think it's not directly related to elfinder connector.
Did you try to create new website with minimal dependencies, integrated pipeline mode and with elfinder connector?

best
Chris
Apr 21, 2014 at 6:00 AM
Edited Apr 21, 2014 at 6:01 AM
Hi Chris,

This is the error that I get:
Image

I used the test project that you shared on 'source code' page and I hardly make any changes in it except updating the elfinder section in web config from:
<elFinder apiVersion="2.0" localFSRootDirectoryPath="c:\users" localFSThumbsDirectoryPath="c:\users\.thumbs" rootDirectoryName="Root" uploadMaxSize="20M"
     defaultVolumeName="LocalFileSystem" baseUrl="http://localhost:56439/data/" baseThumbsUrl="http://localhost:56439/data/.thumbs/">
</elFinder>
to:
<elFinder apiVersion="2.0"
    localFSRootDirectoryPath="C:\test"
    localFSThumbsDirectoryPath="C:\test"
    rootDirectoryName="Root"
    uploadMaxSize="20M"
    defaultVolumeName="LocalFileSystem"
    baseUrl="/data/"
    baseThumbsUrl="/data/"
    duplicateFilePattern="Copy of {0}"
    duplicateDirectoryPattern="Copy of {0}"
    thumbsSize="48,48">
  </elFinder>
I just managed to get it to work by adding this line:
<validation validateIntegratedModeConfiguration="false"/>
Under the <system.webserver> section. However is this alright? As it seems this code just simply ignore the error while the error still persist.

Thank you Chris and kind regards,
Stefanto
Apr 21, 2014 at 8:42 PM
Well, I think that setting this option to "false" should not be a problem, but you can check here for further information:
http://www.iis.net/configreference/system.webserver/validation
It looks like that kind of problems exists when you are switching from Classic mode (and/or IIS6) to Integrated mode (in IIS7+).

Best,
Chris
May 5, 2014 at 11:57 AM
Many thanks Chris, it seems to be working fine so far.

I've made a donation for you, keep up the good work and all the very best.

Kind regards,
Stefanto
May 6, 2014 at 6:58 AM
Great, I'm glad you make it.

Thanks for donation, will try to find some time to expand connector.

best,
Chris