All Button disabled

Nov 23, 2012 at 2:52 PM

I'm using elFilder connector for my project with config: asp.net webform, iis 7, .net framework 4.

But all buttons are disabled.

Please help me?

Coordinator
Nov 23, 2012 at 8:19 PM

That's strange, did you look at the javascript/error console in a browser? Do you see any files and folders in elFinder?

Please paste another screenshot since the first one doesn't show.

Also you could try looking at "Developer tools" in Chrome or F12 in IE to check the requests to and from elFinder.connector handler.

Nov 28, 2012 at 7:46 AM

Hi, error happens when i download source code, then add references to it.

But when i download only DLL and reference to it, it's ok.

How i config

localFSRootDirectoryPath="c:\users"

to:
localFSRootDirectoryPath="~/users"

(directoryPath is webbase path)?

Thanks so much.
Coordinator
Nov 29, 2012 at 7:42 AM
Edited Nov 29, 2012 at 7:43 AM

The

localFSRootDirectoryPath

setting needs to point to physical absolute path, so you need to know this path. If you are on a shared hosting then you can get the path using:

HttpContext.Current.Server.MapPath( null )

Returned value set as localFSRootDirectoryPath in web.config.

May 7, 2013 at 3:17 PM
kzmorzynski wrote:
The localFSRootDirectoryPath setting needs to point to physical absolute path, so you need to know this path. If you are on a shared hosting then you can get the path using: HttpContext.Current.Server.MapPath( null ) Returned value set as localFSRootDirectoryPath in web.config.
hi
please let me know how can I set localFSRootDirectoryPath in shared hosting ?

these are not work:
--> localFSRootDirectoryPath = HttpContext.Current.Server.MapPath( "~/Files" )
--> localFSRootDirectoryPath="~/Files"
Coordinator
May 7, 2013 at 5:19 PM
You should invoke HttpContext.Current.Server.MapPath( "~/Files" ) in Application_Start. I use the following pattern in my apps (I also use log4net):
protected void Application_Start()
{
    log4net.Config.XmlConfigurator.Configure();
    _log.Info( "Starting application on " + DateTime.Now + " at location: " + HttpContext.Current.Server.MapPath( null ) );
}
You could also try to print this in your Razor view:
@HttpContext.Current.Server.MapPath( "~/Files" )
Now copy the printed value into web.config setting localFSRootDirectoryPath and presto! :)
May 8, 2013 at 10:20 AM
this works for me, try putting this c# code in your code behind, it will gives you the physical path of the server;
HttpContext.Current.Request.PhysicalApplicationPath
Coordinator
May 8, 2013 at 1:55 PM
Thank you dotnetdreamer, your solution is also correct.